ArchiCAD 17 Installer not running

ArchiCAD 17 installers for Hotfix’s will only run in Java 7 on the Mac. If you have Mac OS 10.10.x for example you will have Java 8 installed by default. You will need to remove Java 8 and install Java 7 to run the installers, below is what I had to do.

1. Uninstall Oracle Java by deleting the Java Plugin file

Uninstalling Oracle Java involves deleting the Java Plugin file JavaAppletPlugin.plugin.

To uninstall Java, you must have Administrator privileges.

  1. Click on the Finder icon located in your dock
  2. Click on Applications tab on the sidebar
  3. In the Search box enter JavaAppletPlugin.plugin
  4. This will find the JavaAppletPlugin.plugin file
  5. Right click on JavaAppletPlugin.plugin and select Move to Trash

 

2. Reboot
3. Install Java 7 from here